CentOS7用yum update更新了内核后,重启便成了新内核了。但有些软件可能与新内核不太兼容,于是想换回老内核。网上找了下,这篇文章救了我:
http://www.cnblogs.com/kevingrace/p/5821499.html
首先
uname -a
或者
uname -r
看看当前内核是什么。
然后
cat /boot/grub2/grub.cfg
可以看看开机时的排列顺序,一般第一个就是新内核,第二个是旧一点的,如果更新过多次那就依次从新至旧。
然后
vi /etc/default/grub
将GRUB_DEFAULT=saved 改成 GRUB_DEFAULT=0
显然0就是最新的,我改成GRUB_DEFAULT=1是更新前的.
然后配置要生效,要执行
grub2-mkconfig -o /boot/grub2/grub.cfg
然后reboot吧
再看看uname -r
这样系统换回了更新前的旧内核啰!
以上适用于CentOS7,如果是CentOS6的话,很简单,只需要修改/etc/grub.conf 文件即可。
Tags: ,
使用 dnf 最快源: /etc/dnf/dnf.conf 添加 fastestmirror=true
关于DNF的配置最全官方文档:
http://dnf.readthedocs.io/en/latest/conf_ref.html
Tags: ,

CentOS 6安装chromium浏览器

快乐无极 , 2015/11/14 21:11 , 服务器 » Linux , 评论(0) , 阅读(2045) , Via 本站原创
1、切换到root:
su - 或者 sudo -i
2、下载新的软件源定义:
cd /etc/yum.repos.d
wget http://people.centos.org/hughesjr/chromium/6/chromium-el6.repo
3、安装Chromium:
yum install chromium
这样就安装完成了。

chromium不能直接在root下运行,如果要在root用户下运行,必须指定一个个人信息存储文件夹。指定参数 --user-data-dir 。
Tags: ,
默认状态下,Windows Server 2008 R2 远程桌面中,一个用户只能进行一个会话,也就是说已经有一个用户账号登录到远程桌面了,如果其他人再用这个用户账号登录的话,会把之前登录的用户账号自动踢掉。
解决方法:开始-管理工具-远程桌面服务-远程桌面会话主机配置
双击编辑设置下面的“限制每个用户只能进行一个会话”,打开之后切换到常规选项,把“限制每个用户只能进行一个会话”前面的勾取消掉。
最后,应用,确定。

redis安装使用配置

快乐无极 , 2015/07/13 14:46 , 服务器 , 评论(0) , 阅读(1236) , Via 本站原创
一、安装前的准备
下载redis
http://redis.io/download
官方只提供Linux源码下载,Windows版可以在 https://github.com/MSOpenTech/redis/releases 下载到,但只支持64位。
PHP的redis扩展下载:http://pecl.php.net/package/redis

二、使用配置 (Windows环境下)

1.启动redis服务器端
进入redis目录后 开启服务  (注意加上redis.conf)
redis-server.exe redis.conf
redis会自动保存数据到硬盘,暂时不确定目录在哪

2.另外开启一个命令行窗口 进入redis目录下 (注意修改自己的ip,默认的端口为6379)

redis-cli.exe -h 192.168.10.61 -p 6379
(如果不加 -h 则默认为本机 127.0.0.1 ,如果不加 -p 则默认6379端口)
测试下set get 是否正常使用:

redis 127.0.0.1:6379> SET foo bar
OK
redis 127.0.0.1:6379>KEYS *
1) "foo"
redis 127.0.0.1:6379> GET foo "bar"
Tags:
Windows10中自带的Server:Microsoft-IIS/10.0,然后这个10却让原本支持组件无法安装了,php manager组件安装时提示“必须安装IIS7以上才可以安装”。那是不是真的就没法在新的IIS上安装了呢?显然不是的。自IIS7以来,微软的IIS更改并不大,架构一致,几乎所有IIS7能用的组件都能够在IIS7.7/8/8.5/10上安装。微软脑子秀逗,跳过了9,以为能解决版本识别的问题,没想到弄成10,还是出现了版本识别的问题,真是自己打自己的脸啊!
那么怎么办呢?改注册表!
打开regedit,找到:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3SVC\Parameters
右侧的 MajorVersion 是DWORD值,它的值十进制是10,把它改成9。然后运行php manager安装程序即可顺利安装上了!记得装完之后改回来。
php manager的最新下载地址是:http://phpmanager.codeplex.com/releases/view/69115
而IIS URL Rewrite 2.0更是奇怪,简体中文版的这个组件无法安装,同样也是检测版本不正常,而英文版却能正常安装。
64位英文版下载地址是:http://go.microsoft.com/fwlink/?LinkID=615137
简体中文版下载地址是:http://download.microsoft.com/download/4/E/7/4E7ECE9A-DF55-4F90-A354-B497072BDE0A/rewrite_x64_zh-CN.msi

但是面对一堆英文,有些人肯定也会头疼了,那么简体中文版到底能不能装上。
也能!还是改注册表,我通过分析MSI发现它会检测
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\InetStp
也是 MajorVersion 项,这个也是 dword 值 10(注意是十进制),把它改成9,结果顺利安装上了!
这不得不吐槽微软一句:Win10真尼玛坑爹!
Tags: ,
分页: 1/7 第一页 1 2 3 4 5 6 7 下页 最后页 [ 显示模式: 摘要 | 列表 ]